Configure Nox to work with OSRS

Asentrix

Asentrix

Administrator
Owner
Developer
Messages
303
Joined
Oct 2, 2019
Reaction score
78
Points
28
Credits
33,347
Utilizing this method, we can bot OSRS/RS3 mobile, while minimized.
It doesn't require a VM which is awesome too!
To get started, we'll need to download the following emulator:

Click here to download nox
Once it finishing downloading, go ahead and install it. Once installed, you will need to change a few settings.


Step 1
We need to download, install and configure osrs mobile on nox.
By default, the app will crash constantly and wont work, so we will need to make a few changes later.
To start off, download the "osrs mobile apk" from apkpure, or any other apk download website
Click here to download from APKPure
Once you have finished downloading the APK, drag and drop it onto the Nox window, and it should install osrs mobile onto nox.
Finally, before we can run it, we need to fix the crashing issue.
Navigate to your nox installation folder, it should be in the following location

"C:\Program Files\Nox\bin\"
Once you're in the folder, run the .exe file "MultiPlayerManager.exe"
We need to create a new emulator, so click the blue button down the bottom that says "Add emulator" and select version Android 7.X.X.X
Create a shortcut of the new emulator onto your desktop for ease of access later.
Now, osrs wont crash when we play it, yay!
Step 2
Firstly, open the settings menu, by clicking the settings icon on the top right of the emulator.
Once the system settings open, navigate to the advanced settings.

Change the performance mode to the highest option your PC can handle.
Change the resolution to the tablet setting (1920x1080) or whatever the resolution of your screen is (some laptops are 1280x720)
Make sure graphics rending mode is on "Enhanced compatibility mode beta (OpenGL+)
Put the frames on 60.
Now , go to the property settings.
For device model, select LGE LGM-V300K
The IMEI can be random, just click create a few times, as well as the mobile number.
Make sure the network connection is turned on.
 
Last edited:
Top Bottom